MIDAS KnowledgebaseMIDAS Knowledgebase

I've encountered a "POSIX::tzset not implemented on this architecture" error

Note: this article applies to MIDAS v4.07 or earlier

"tzset" is common Perl command which our MIDAS scheduling software utilizes when calculating times and time zones.

If you're running MIDAS v4.07 or earlier on a Windows-based platform and are using a "Strawberry Perl" distribution of Perl, you may encounter an error informing you that tzset isn't implemented on your architecture. (If you're running on a *nix based server, or running on Windows with a different distribution of Perl, you are unlikely to see this error)

We understand that from around June 2010, tzset is no longer recognized or implemented in Strawberry Perl. We have no idea why this is the case, as there is very little information available from the developers of Strawberry Perl. It is unknown whether this is just a bug/glitch in Strawberry Perl, or if this common functionality has been permanently and intentionally removed.

The good news is that as of MIDAS v4.08 you will be able to use Strawberry Perl distributions again if you so desire. Whilst the lack of tzset support in Strawberry Perl continues to persists in their current releases, MIDAS v4.08+ can work around this issue.

However, if you're attempting to install/run an earlier version of MIDAS (v4.07 or earlier), and encounter this issue with Strawberry Perl on Windows, you will need to switch to an alternative Perl distribution. We suggest ActivePerl which is free, and the leading commercial-grade distribution of the open source Perl scripting language. It may be downloaded from:
http://www.activestate.com/activeperl/downloads

ActivePerl supports tzset, and once you're running ActivePerl instead of Strawberry Perl, you should no longer encounter "POSIX::tzset not implemented on this architecture" errors in MIDAS v4.07 or earlier.

You might also be interested in...
» » »

← Return to Knowledgebase