MIDAS KnowledgebaseMIDAS Knowledgebase

How do I import client data from another application into MIDAS?

You can import clients from other applications into MIDAS via MIDAS Admin Options → Manage MIDAS → Database → Database Tools → Import Data.

WARNING: We strongly advise backing up your database before importing any data

Pre-Requisits

Using the import tool, you can import client data into MIDAS v4.06 or later, that is either in a .csv (Comma Separated Values), or .txt (Tab, or other character, Delimited) file format.

Preparing your data for import

If there is an "Export" feature in your existing 3rd party software application, use it to export your client or contact data, ideally as either a Comma Separated Value .csv file, or a delimited .txt file. If your software doesn't allow you to export in one of these formats, you will need to further convert your exported data before you can import it into MIDAS. For example, if your application will only allow you to export in an Excel spreadsheet format (either as an .xls or .xlsx file), you will then have to open your file in Excel and re-save it again as a .csv or .txt file.

Alternatively, if you wish to create your own data for import into MIDAS, you can do this in a spreadsheet application, such as Excel, and save your data as a .csv or .txt file. If creating your own spreadsheet in the fashion, be sure to include each field (such as name, organization, phone number, etc) as a separate column within the spreadsheet, and then each individual client record as a new row.

Exporting contacts from Microsoft Outlook
  1. In Outlook, select "File → Import and Export"
  2. In the Import & Export wizard, select "Export to a file" and click "Next"
  3. Select either the "Comma Separated Values (Windows)" or "Tab Separated Values (Windows)" option and click "Next"
  4. When prompted for the folder to export from, select "Contacts", and click "Next"
  5. Choose a location to save your exported data to, click "Next" and then "Finish"
  6. Your client/contact data is now ready to be imported into MIDAS!
Exporting contacts from Mozilla Thunderbird
  1. In Thunderbird, select "Tools → Address Book"
  2. Select the address book containing clients/contacts you wish to add to MIDAS
  3. Select "Tools → Export"
  4. A Save dialog will appear. Make sure to set the "Save as type" option to either "Comma Separated" or "Tab Delimited".
  5. Save your file
  6. Your client/contact data is now ready to be imported into MIDAS!

Once you have your exported or manually created data prepared, you are ready to use the import tool to import the data into MIDAS....

Step 1 - Specify file to import


Import client data into MIDAS
Use the "Browse" button to locate your .csv or .txt client data file to import. If each field in your data file is "Comma Separated", select the "Comma" delimiter option. If each field is separated by a "Tab", select the "Tab" delimiter option. If each file in your data file is separated by a different character (i.e. the "|" (or "pipe") character), select the "Custom" option, and enter the delimiter character. If the first record (or "row") in your data file contains field names, rather than actual client data select the "First row contains field names" option to prevent this data being imported into MIDAS.
Before clicking the "Next Step" button, be sure to specify that you are importing client (and not user) data.

Step 2 - Specify import options

The next screen will show you a "snapshot" of the data you are about to import in a table:
Import from Excel or another spreadsheet into MIDAS
At the top of each column in the table is a drop-down list allowing you to "assign" each column to a specific client field within MIDAS. For example, if the first column of your data file contains client names, select "Client" at the top of this column. Do this for all columns you wish to import. If your data contains a column, or columns, that you don't wish to import data from, select the <Don't Import> option from the drop-down at the top of these rows.

You will then have the option of which database you wish to import the data to (if you're running multiple databases from a single MIDAS interface).

Step 3 - Import

After a few seconds (depending upon the amount of data being imported), you should then see the following screen, indicating how many new records have been imported:
Import client data from a 3rd party application
You might also be interested in...
» » »

← Return to Knowledgebase