MIDAS KnowledgebaseMIDAS Knowledgebase

During install, I'm informed that there are required modules missing - what do I do?

Occasionally, if a barebones/minimal install of Perl has been configured in your server, some of the PERL modules required by MIDAS may be missing.

MIDAS requires the following Perl modules:

Archive::Tar
DBI
DBD::mysql
Digest::MD5
Digest::SHA
Encode
LWP::Simple
LWP::UserAgent
Memoize
MIME::Base64
Time::Local
XML::Simple

The following optional modules may also be required depending upon your needs:

Authen::SASL (Only required if you wish MIDAS to send email via SMTP, and your SMTP server requires SSL connections)
LWP::Protocol::https
(Only required if you wish your MIDAS to check for updates over secure https connections. If not installed, MIDAS will use http connections instead)
Net::Config
(Only required if you wish MIDAS to send email via SMTP)
Net::SMTP
(Only required if you wish MIDAS to send email via SMTP)
Net::SMTP::SSL
(Only required if you wish MIDAS to send email via SMTP, and your SMTP server requires SSL connections)
Net::SMTP::TLS
(Only required if you wish MIDAS to send email via SMTP, and your SMTP server requires TLS connections)
Time::Piece
(Only applicable to MIDAS v4.08+, and only required if your Perl distribution doesn't support POSIX/tzset - such as Strawberry Perl)

All these modules can be freely downloaded & installed on your server from www.cpan.org. MIDAS will inform you if any required modules are still missing when you attempt to install the software. Once you have installed these modules, please run the MIDAS installation again.

You might also be interested in...
» » »

← Return to Knowledgebase